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Installing R and RStudio

If you haven’t already done so (on personal machines), install R and RStudio
now:

I R (http://cran.r-project.org/)
I R Studio

(http://www.rstudio.com/products/rstudio/download/)

And start up RStudio.
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The Data Analytics Process

http://r4ds/diagrams/data-science.png/
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Details
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http://r4ds/diagrams/
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RStudio
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RStudio IDE

The RStudio IDE provides four “panes”.
There are two primary panes:

I Console: Where you run “live” R code.
I Source: The editor where you can write

scripts to save (for reproducibility).

The two other panes will show:

I Plots
I Help: Documentation for R functions
I Environment: the R objects you have

created (also called Workspace)
I History: list of all the R code that is run in

the console.
I . . . (many other things)
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Customizing the Rstudio IDE

The RStudio IDE can be customized:

I Tools -> Global Options ...

Description of the options can be found here:
http://support.rstudio.com/hc/en-us/articles/
200549016-Customizing-RStudio

Under General:

I Uncheck “Restore .RData into workspace at startup”
I Save workspace to .RData on exit to Never
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R Projects

I It’s good practice to keep all your files associated with a
project in one place (data, scripts, figures, reports, etc.).

I RStudio facilitates this with Projects
I Each Project has its own working directory, workspace, history,

and source documents
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R Project Details

I When a new project is created, RStudio:
I Creates a project file (with an .Rproj extension) within the project

directory. This file contains various project options and can also
be used as a shortcut for opening the project directly from the
filesystem.

I Creates a hidden directory (named .Rproj.user) where
project-specific temporary files (e.g. auto-saved source
documents, window-state, etc.) are stored.

I Loads the project into RStudio and display its name in the
Projects toolbar (which is located on the far right side of the main
toolbar).

RStudio documentation for Projects: http://support.rstudio.com/hc/
en-us/articles/200526207-Using-Projects
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Your Turn #1 : Create a R Project

Create a new R Project for this class by clicking on drop-
down at top right section of RStudio.

I It gives you the option to start a new directory (i.e.,
folder)

I Avoid using spaces in the project name (e.g., ST597)
I I usually create projects in google drive or dropbox so I

can access the files from multiple computers
I For computer lab, use X: drive
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Using RStudio: Console Pane

Go to the console pane and let’s do some math.

5+6-1
#> [1] 10

Save the results as an object named x

x = 5+6-1

To see the value of x, just enter x at the prompt

x
#> [1] 10

Note: Most resources for R will use <- (the two symbols < and -) instead of = to
assign x the numeric value of 5+6-1.
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R Variables

Make another object y and add it to x

y = 90
x + y
#> [1] 100

We can assign multiple variables to the same value

a = b = 0

a
#> [1] 0
b
#> [1] 0

ST 597 | Sp 2017 13/1



Using RStudio: Environment (Workspace) Tab

We can look at all the variables in our workspace by going to the
Environment tab (upper right pane on my configuration).

Or, type ls() for a list in the console:

ls()
#> [1] "a" "b" "course_url" "x" "y"
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R Packages

I Contributed R Packages are what makes R so great.
I An R package can contain: R functions, data, help pages,

vignettes, non-R code (e.g., C++, Fortran)
I The Base R distribution actually consists of 14 packages
I There are 15 Recommended packages that come shipped

with all binary distributions.
I And over 12,000 additional packages
I We will use several packages for this class; good thing they

are so simple to use!
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Using R Packages

It takes two steps to use the functions and data in an R package

1. Install the package
I i.e. download the package to your computer
I this only needs to be done one time
I install.packages()

2. Load the package
I i.e. tell R to look for the package functions and/or data
I this needs to be done every time R is started (and you want to

use the package)
I library()
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R Package Set-up (Lab Computers)

These steps are only necessary for Lab Computers:

1. Create sub-directory RPackages on your X: drive.
I i.e. Create new folder in X: drive called RPackages
I X:/RPackages

2. TBD

ST 597 | Sp 2017 17/1



R Package Installation

1. Install the package on your computer
I Tools -> install.packages...
I Or, in the console type: install.packages(pkgnames)
I Packages only need to be installed one time on a computer; do

not re-install

2. Then, load into workspace to have access to all functions,
datasets, and help files
I Click on Packages tab and check boxes
I Or, type library(pkgname) or require(pkgname)

3. Packages can be updated to ensure latest functionality and
bug fixes
I Tools -> Check for Package Updates...
I Or, in console update.packages()
I This just re-installs and writes over the old package

If you don’t have root permission, then use the lib= argument.
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Installing and Loading Packages

Your Turn #2

1. Install the package tidyverse
2. Load the packages into the workspace
3. Did you get any warnings? Make a note of these.
4. Ensure you have loaded it correctly:

I Type ?mpg in the console to see the help documentation
for the data mpg from the ggplot2 package.

I Type ?ggplot in the console to see the help
documentation for the function ggplot()
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Note on tidyverse package

I The tidyverse package is really just a wrapper to load
several related R packages
I ggplot2 for graphics
I dplyr for data manipulation
I tidyr for getting data into tidy form
I readr for loading in data
I tibble for improved data frames
I purrr for functional programming

I This provides a nice shortcut to load all of these packages
with library(tidyverse) instead of each separately:

#- the hard way
library(ggplot2)
library(dplyr)
library(tidyr)
library(readr)
library(tibble)
library(purrr)
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Function conflicts

I Sometime you will come across functions from different packages that
have the same name
I For example, filter from package:dplyr and filter from

package:stats
I If both packages are loaded, the function in the package that was

loaded last will be invoked when calling the function.
I The other functions are said to be masked.

I E.g., loading dplyr:

Attaching package: 'dplyr'
The following object is masked from 'package:stats':

filter, lag

I If you want a specific function, add the package name separated by
two colons

?filter
?stats::filter
?dplyr::filter
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Note on using library()

I Packages only need to be installed (install.packages())
one time on your computer

I But packages need to be loaded (library()) every time
you start a new R session
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Using RStudio: Source Pane

I The source pane can save you lots of pain.
I This is where you will do most of your work.
I By executing commands from within the source editor rather

than the console it is much easier to reproduce sequences of
commands as well as package them for re-use as a function.

I Scripts can be saved for later use or sharing.

RStudio documentation: http://support.rstudio.com/hc/en-us/
articles/200484448-Editing-and-Executing-Code
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Your Turn #3

1. Create a new R script

I File -> New File -> R Script

2. Copy and paste the following code (to make a scatter plot)
into the new R script

#- Load the fuel economy data
library(tidyverse) # note: mpg data is from ggplot2 package
data(mpg) # loads the data (not necessary, but helpful

# to specify)

#- Make plot
ggplot(data=mpg) +

geom_point(aes(x=displ, y=hwy))

#- Save plot
ggsave("mpg.pdf")

#- Save data
write_csv(mpg, path="mpg.csv")
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Your Turn #4

3. Run the code in the console (Highlight all code and
Ctrl+Enter)

4. Open the plot (mpg.pdf) in a pdf viewer and open the data
(mpg.csv) in a spreadsheet program

I where did you find these files?

5. Add the following properties to geom_point() and re-run:

I Map the color of the points to the class (color=class)
I Map the size of the points to the number of cylinders (hint:
size=cyl)

ST 597 | Sp 2017 25/1



Scripts for interactive analysis and reproducibility

I Working in the source pane instead of the console will save
you time as you interact with the data.

I For example, you now have the code to produce a nice scatter
plot with control for point size and colors.

I Working with a script will help with Reproducible Data
Analysis

I Dangers of Point and Click Approach
I The # symbol marks a comment. The rest of the line is

commented (not read by R).

y = 10 # set y equal to 10
y = 5 # set y equal to 5
# y = 1 # set y equal to 1 (Note: this will not be run by R)
y
#> [1] 5

ST 597 | Sp 2017 26/1

http://www.johndcook.com/blog/reproducible/
http://www.johndcook.com/blog/reproducible/
http://kc.vanderbilt.edu/quant/Seminar/ReproducibleAnalyses.pdf


Your Turn #5

Save your plot script in the project directory.

1. Create a subdirectory R to keep all your R scripts.
2. Use the extension (.R) for R scripts

I For example: mpg-plot.R

3. Save mpg-plot.R in the R subdirectory
4. (Optional) Create subdirectories data and figures. Modify

the script to add the components to the correct subdirectory

I ggsave("figures/mpg.pdf")
I write_csv(mpg, path="data/mpg.csv")
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History

I RStudio keeps track of everything entered into the console in the
History tab (top right pane in my config)

I Here you can send lines of code to the console or source
I When working in the console, you can also use Up-arrow to scroll

through recent commands
I Or type the first few characters of your command and use
Ctrl+Up-arrow

I Example: Type gg, then Ctrl+Up-arrow to see a list of your
recent commands that started with “gg”

I It is a good idea to save anything from the history that you may need
again in a script.

I If you are working under an R Project, then your history should save
automatically and be available next time to start up that project.

RStudio documentation: http://support.rstudio.com/hc/en-us/
articles/200526217-Command-History
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RStudio Keyboard Shortcuts

I You can improve your productivity by learning keyboard shortcuts
I In editor:

I Ctrl+Enter: send code to console
I (Command+Enter on Mac)

I Ctrl+2: move cursor to console
I Ctrl+a: select all

I In console

I Up_arrow: retrieve previous command
I Ctrl+up arrow: search commands
I Ctrl+1: move cursor to editor

I Tab complete

I start typing a variable or function name and then Tab
I For functions, enter function name then parenthesis “(” then Tab

and it will show you possible function arguments.

mean( + Tab

I We will explore this more when we introduce functions
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RStudio Help Pages

I Check out Help tab
I RStudio Main Help Page
I cheat sheets
I RStudio IDE
I Keyboard Shortcuts

I Or Alt+Shift+K

I Getting R Help
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Using R

ST 597 | Sp 2017 31/1



R Resources

There is no shortage of free resources for learning R.

The official reference list is here:
http://cran.r-project.org/other-docs.html

I Look for options that are more recent. E.g.,
I Base R Cheatsheet
I http://cran.r-project.org/doc/contrib/
Baggott-refcard-v2.pdf

I http://cran.r-project.org/doc/contrib/Torfs+
Brauer-Short-R-Intro.pdf
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Bank Discrimination?

Did a bank discriminatorily pay higher starting salaries to men
than to women?

Let’s examine some data of beginning salaries for entry-level
clerical employees hired by the bank between 1969 and 1977.

The data can be found on the webpage at: http:
//mdporter.github.io/ST597/data/salary.csv
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Load the Starting Salary Data into R

We can read this into R several ways:

1. From Rstudio: Tools -> Import Dataset -> From
Web URL ...

2. Download file and use Tools -> Import Dataset ->
From Text File ...

3. Use command line (reproducible option - save in script)

library(tidyverse)
url = 'http://mdporter.github.io/ST597/data/salary.csv' # use quotes
salary = read_csv(url) # name the data: salary
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View the data

1. RStudio Viewer: Go to Environment tab, and click on
spreadsheet symbol next to salary.

2. Or, type View(salary) (with uppercase V)

Notice, we can also just type the data name salary into the
console

salary
#> # A tibble: 93 × 2
#> Salary Sex
#> <int> <chr>
#> 1 3900 Female
#> 2 4020 Female
#> 3 4290 Female
#> 4 4380 Female
#> 5 4380 Female
#> 6 4380 Female
#> 7 4380 Female
#> 8 4380 Female
#> 9 4440 Female
#> 10 4500 Female
#> # ... with 83 more rows
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Quick view of the data

The function glimpse() provides a brief view of the data

glimpse(salary)
#> Observations: 93
#> Variables: 2
#> $ Salary <int> 3900, 4020, 4290, 4380, 4380, 4380, 4380, 4380, 4440, 4...
#> $ Sex <chr> "Female", "Female", "Female", "Female", "Female", "Fema...

The function summary() gives an overall summary

summary(salary)
#> Salary Sex
#> Min. :3900 Length:93
#> 1st Qu.:4980 Class :character
#> Median :5400 Mode :character
#> Mean :5420
#> 3rd Qu.:6000
#> Max. :8100
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Make Boxplots

ggplot(data=salary) +
geom_boxplot(aes(x=Sex, y=Salary))
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Make Histograms

ggplot(data=salary) +
geom_histogram(aes(x=Salary), binwidth=500) +
facet_wrap(~Sex) + coord_flip()
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Get Average Salary by Sex

salary %>% # start with salary data
group_by(Sex) %>% # group or split by `Sex` column
summarize(avg=mean(Salary)) # get the mean of `Salary` column

#> # A tibble: 2 × 2
#> Sex avg
#> <chr> <dbl>
#> 1 Female 5138.852
#> 2 Male 5956.875

# for each group
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Comparing summary statistics

The average male salary was $818.02 larger than the average
female salary.

Can we conclude that there is gender discrimination?

Your Turn #6

1. Would you feel any different if the reported difference
had less or more digits? E.g.,
I $818
I $818.022541
I around $800

2. Is this an experimental or observational study?
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Comparing summary statistics

The average male salary was $818.02 larger than the average
female salary.

Can we conclude that there is gender discrimination?

Your Turn #7

1. Would you feel any different if the reported difference
had less or more digits? E.g.,
I $818
I $818.022541
I around $800

2. Is this an experimental or observational study?
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